• RE: Portal Does not forward messages

    @Dirkie123 I would like to investigate this topic a bit more. Could you send me some logs I can’t see which device / SIM card you are using in your tests. You can DM me or send details to hi@iot.t-mobile.nl?

    posted in Network
  • RE: Not able to connect BG96

    It seems to be an issue in the T-Mobile dashboard with registering new devices. The backend still works so apps connected via an API still receive the messages.

    posted in T-Mobile NL Connectivity Workplace and API
  • Not able to connect BG96

    I have a RAK5010 module with a Quectel BG96. According the logs it seems that the device connects successfully, but the device is not registered in the T-Mobile dashboard.
    I have updated the BG96 firmware to 01.017.01.017.

    Below you can find the logs of the AT commands.

    00> 
    00> 
    00> ==== Start NB-IoT App ====
    00> [BG96|bg96Setup] BG96 Starting
    00> [BG96|sendAT] AT | Error
    00> 
    00> RDY
    00> [BG96|sendAT] AT | Error
    00> 
    00> APP RDY
    00> AT
    00> 
    00> OK[BG96|sendAT] AT | Oke
    00> [Main] Setup | Oke
    00> 
    00> AT
    00> 
    00> OK
    00> AT&F
    00> 
    00> OK
    00> AT+GMM
    00> 
    00> BG96
    00> 
    00> OK
    00> AT+GMR
    00> 
    00> BG96MAR02A07M1G
    00> 
    00> OK
    00> AT+QAPPVER
    00> 
    00> +QAPPVER: 01.017.01.017
    00> 
    00> OK
    00> AT+CGSN
    00> 
    00> [REMOVED/MASKED]
    00> 
    00> OK[Main] BasicData | Oke
    00> 
    00> AT+CFUN=0
    00> 
    00> OK
    00> AT+QCFG="BAND",1,1,80,1
    00> 
    00> OK
    00> AT+QCFG="NWSCANMODE",3,1
    00> 
    00> OK
    00> AT+QCFG="NWSCANSEQ",030102,1
    00> 
    00> OK
    00> AT+QCFG="IOTOPMODE",1,1
    00> 
    00> OK
    00> AT+QCFG="ROAMSERVICE",255,1
    00> 
    00> OK
    00> AT+CFUN=1
    00> 
    00> OK[Main] Network Settings | Oke
    00> 
    00> AT+CIMI
    00> 
    00> [REMOVED/MASKED]
    00> 
    00> OK
    00> AT+COPS=0
    00> 
    00> OK
    00> AT+CGDCONT=1,"IP","CDP.IOT.T-MOBILE.NL"
    00> 
    00> OK
    00> AT+COPS=1,2,"20416",9
    00> 
    00> OK
    00> AT+CSQ
    00> 
    00> +CSQ: 14,99
    00> 
    00> OK
    00> AT+QNWINFO
    00> 
    00> +QNWINFO: "CAT-NB1","20416","LTE BAND 8",3747
    00> 
    00> OK[Main] Network Connect | Oke
    00> 
    00> AT+CPSMS=0
    00> 
    00> OK[Main] Disable PSM | Oke
    00> 
    00> AT
    00> 
    00> OK[BG96|sendAT] AT | Oke
    00> [Main] Check device | Oke
    00> [BG96|sendData] RSSI=14
    00> 
    00> AT+QIACT=1
    00> 
    00> OK
    00> AT+QIACT?
    00> 
    00> +QIACT: 1,1,1,"10.128.1.79"
    00> 
    00> OK
    00> AT+QIOPEN=1,0,"UDP","172.27.131.100",15683
    00> 
    00> OK
    00> 
    00> +QIOPEN: 0,0
    00> AT+QISEND=0,7
    00> 
    00> > 1A1A1gy
    00> SEND OK
    00> AT+QICLOSE=0
    00> 
    00> OK
    00> AT+QIDEACT=1
    00> 
    00> OK[Main] Send data | Oke
    00> 
    00> AT
    00> 
    00> OK[BG96|sendAT] AT | Oke
    00> [Main] Check device | Oke
    00> [BG96|sendData] RSSI=19
    00> 
    00> AT+QIACT=1
    00> 
    00> OK
    00> AT+QIACT?
    00> 
    00> +QIACT: 1,1,1,"10.128.1.79"
    00> 
    00> OK
    00> AT+QIOPEN=1,0,"UDP","172.27.131.100",15683
    00> 
    00> OK
    00> 
    00> +QIOPEN: 0,0
    00> AT+QISEND=0,7
    00> 
    00> > 1A1A1gy
    00> SEND OK
    00> AT+QICLOSE=0
    00> 
    00> OK
    00> AT+QIDEACT=1
    00> 
    00> OK[Main] Send data | Oke
    

    For another device/PoC I used roughly the same AT commands and there I have a succeful connection. Is my device blocked by the server or something? Who can help?

    Thanks in advance.

    Martin

    posted in T-Mobile NL Connectivity Workplace and API
  • RE: Portal Does not forward messages

    Hi Dirkie, did you add and remove a dummy IMEI in your project? Did it help? Please let us know so that we can help with further troubleshooting.
    Regards, Uta

    posted in Network
  • Oeps

    Hi,

    I had a bricked SIM7020e module and bougth a new one, I forgot to register the IMEI first and can’t register it. It was suggested to contact support. Can this device be activated ?
    Thanks, Joop!

    Please see the screenshot of the message,
    Thanks again for your support,

    9d33d6f5-f2b6-4fd7-a476-39fa133739ff-image.png

    posted in Feedback and General Account Issues
  • RE: Arduino MKR NB1500: lukt niet om te verbinden.

    @Martijn-Kooijman said in Arduino MKR NB1500: lukt niet om te verbinden.:

    And I agree that psm might give better overall results if you send often but when you send once in a while (like I do) I think turning it off is more power efficient?

    That depends on many things. Turning R4 off means you have to attach to the network every time you turn it on, that can consume a lot of energy.

    posted in T-Mobile NL Connectivity Workplace and API
  • RE: Arduino MKR NB1500: lukt niet om te verbinden.

    @Martijn-Kooijman If you want to use network PSM you can’t turn it off.

    @Stefan-de-Lange I dont think its only the board thats not optimised, but also the current arduino implementation. for example you could run the samd21 at lower speed.

    If you want to measure sleep current the MCU should be in deep sleep, so no clock running at all (except maybe RTC to wake it up)

    posted in T-Mobile NL Connectivity Workplace and API
  • RE: Arduino MKR NB1500: lukt niet om te verbinden.

    @Crowdsourcer It’s an arduino development board, it’s not build for low power. So don’t expect too much from it. In practise I get about 7uA deep sleep current with u-blox R4

    posted in T-Mobile NL Connectivity Workplace and API