Testing SIM7000E


  • Hi,

    I have a SIM7000 evaluation board and I want to do some tests with the T-Mobile NB network.

    I can connect to the network, but when I send data (POST) I receive a network ERROR.

    I’m not sure about the port. Normally a webserver uses port 80, but I believe I must use port 5683 for this test.

    Anybody here who succesfully tested the SIM7000 ?

    These are my AT-commands"

    AT
    OK

    AT+CPIN?
    +CPIN: READY
    OK

    AT+CNMP=38
    OK

    AT+CMNB=2
    OK

    AT+NBSC=0
    OK

    AT+CREG?
    +CREG: 0,3
    OK

    AT+CGREG?
    +CGREG: 0,5
    OK

    AT+CGATT?
    +CGATT: 1
    OK

    AT+CPSI?
    +CPSI: LTE NB-IOT,Online,204-16,0x04EB,2086502,343,EUTRAN-BAND8,3747,0,0,-3,-83,-82,20
    OK

    AT+SAPBR=3,1,“APN”,"oceanconnect.t-mobile.nl"
    OK

    AT+SAPBR=2,1
    +SAPBR: 1,3,"0.0.0.0"
    OK

    AT+SAPBR=1,1
    OK

    AT+HTTPINIT
    OK

    AT+HTTPPARA=“URL”,"172.16.14.22:5683"
    OK

    AT+HTTPPARA=“CID”,1
    OK

    AT+HTTPDATA=4,10000
    DOWNLOAD
    OK

    AT+HTTPACTION=1
    OK

    AT+SAPBR=0,1
    +HTTPACTION: 1,601,0
    OK

    Best regards,

    Marcel



  • Hoi Marcel,
    Wij hebben nog geen kans gehad met deze module te werken wezouden er graag eens mee willen testen. In ieder geval bevat deze module niet de CoAp stack die noodzakelijk is om met Oceanconnect te kunnen praten. Binnenkort bieden we andere oplossingen door middel van een andere APN maar tot nu toe kan je wellicht proberen de stack te simuleren door deze libraries te gebruiken en wellicht aan te vullen met jouw module type



  • @eric-barten said in Testing SIM7000E:

    Hoi Marcel,
    Wij hebben nog geen kans gehad met deze module te werken wezouden er graag eens mee willen testen. In ieder geval bevat deze module niet de CoAp stack die noodzakelijk is om met Oceanconnect te kunnen praten. Binnenkort bieden we andere oplossingen door middel van een andere APN maar tot nu toe kan je wellicht proberen de stack te simuleren door deze libraries te gebruiken en wellicht aan te vullen met jouw module type

    Is er al een update over NB-IoT met de SIM7000E?



  • Hoi @andre-rodenburg we hebben zelf geen beschikking over deze module. Als je in de gelegenheid bent naar ons volgende installfest te komen kunnen we samen kijken welke mogelijkheden de module heeft en we kunnen alvast de nieuwe APN testen met een SIM kaart van ons



  • @marcel-duijnisveld said in Testing SIM7000E:

    I’m not sure about the port. Normally a webserver uses port 80, but I believe I must use port 5683 for this test.

    On port 5683 runs a “lightweight” COAP , based on UDP …
    http will most definitely NOT work would be my assumption …

    besides http has more overhead and is therefore less energy efficient 😉

    Here is an UDP implementation of the used COAP protocol: Neulmessenger



  • @eric-barten said in Testing SIM7000E:

    Hoi @andre-rodenburg we hebben zelf geen beschikking over deze module. Als je in de gelegenheid bent naar ons volgende installfest te komen kunnen we samen kijken welke mogelijkheden de module heeft en we kunnen alvast de nieuwe APN testen met een SIM kaart van ons

    Ik heb de module momenteel nog niet binnen, heb wel een paar lijntjes uit staan dus als het voor de 28ste lukt zal ik hem zeker meenemen. Die nieuwe APN klinkt ook interessant, heb je daar meer info over misschien?



  • @andre-rodenburg : We nemen een Sim7000E eval mee op de 28e.
    We stoeien nog even om de laatste Firmware erin te krijgen.
    mvg - John



  • @voske65 Top, ben benieuwd naar de nieuwe APN van t-mobile.



  • @Eric-Barten Het lijkt de goede kant op te gaan met de SIM7000E om op het NB IoT netwerk te komen. Er zijn wel een aantal vragen; Verbinding lijkt via Roaming te gaan, commando CREG? is network registration gives answer Registration Denied. commando CGREG? is network registration status, geeft antwoord registered Roaming.
    Er is wel een ip adres in de reeks van 10.x.x.x verkregen. Het ping commando CIPPING geeft onmiddelijk een ERROR melding terug. Andere vraag is, is er nu een UDP socket open of moet die nog worden geopend. Het commando CIPSTART=“UDP”,"172 enz geeft STATE: PDP DEACT en CONNECT FAIL.
    Heb je suggesties?


Locked
 

Looks like your connection to Internet of Things was lost, please wait while we try to reconnect.