RadioModem cant find the T-mobile NB network - AT+COPS? results


  • I Registered my Sim card by Imei today , and try to connect to the Network using a Sim7000E
    However AT+CREG? always shows 0,2 (Automatic , Searching)
    Operator Check :
    AT+COPS=?
    +COPS: (1,“204 04”,“204 04”,“20404”,0),(1,“204 08”,“204 08”,“20408”,0),(1,“204 16”,“204 16”,“20416”,0),(1,“204 08”,“204 08”,“20408”,8),(1,“204 04”,“204 04”,“20404”,9),(0,1,2,3,4),(0,1,2)

    t-Mobile is available (20416), but never connects.
    Forcing using AT+COPS=1,2,“20416” -> +CME ERROR: no network service
    Remarkable: the Vodaphone (20404) is 2x in the list with NetAct 0 and 9 (=NB support ?)
    Any idea what is wrong? - registration of the Sim went wrong or bad erea coverage indoor?



  • @afzal_m
    Thanks for the personal reply today.
    As discussed, we’ve used the following set to access the T-Mobile NBIOT with the Sim700E:

    ATZ
    AT+CFUN=0
    AT+CNMP=38 // use LTE as preferred mode
    AT+CMNB=2 // use NBIOT as preferred selection
    AT+NBSC=0 // no Scrambling
    AT+CBANDCFG=“NB-IOT”,8 // Set NBIOT to band 8
    AT+CFUN=1
    AT+CREG=1

    This all results in OK

    Now we force to connect:
    AT+COPS=1,2,"20416"
    AT+CREG?

    This results continuous in : +CREG 0,3 : Registration Denied

    Q: Is the Device registration ok ? (Imei)
    I have registered the device twice, as I used by accident non-standard characters the first time for the Device Name
    Can you check plz ?



  • Hi @voske65 thanks for sharing this informations here and it was nice to meet you yesterday!

    I’ve reached out to the heroes from our terminal testing team and radio access network and will get back to you soon 🙂



  • By the way! Did you try it with our without scrambling? Scrambling should be switched off.

    AT+NCONFIG=CR_0354_0338_SCRAMBLING,FALSE



  • @afzal_m
    Scrambling is off - correct.

    AT+NCONFIG=CR_0354_0338_SCRAMBLING,FALSE -> is AT command for uBlox
    AT+NBSC=0 -> AT command for Simcom

    I wait for your confirmation that my Imei registration is checked and correct.



  • @afzal_m
    We’ve booked some progress possibly.
    Above sequence ends in a denied registration on the network.
    however:
    AT+CGREG?
    +CREG:0,5 -> we’re on Roaming

    AT+COPS?
    +COPS:0,2,“20416"”,9 -> we are on T-Mobile network, and on the NBIOT band

    Setting your APN:
    AT+CGDCONT=1,“IP”,"oceanconnect.t-mobile.nl"
    We receive IP adress.

    From here, we cant send any data as sim7000E does not support CoAp.
    So we need UDP direct to be supported 🙂

    FYI: the new Sim7020 will have CoAp support planned, available in May-June



  • @voske65 said in RadioModem cant find the T-mobile NB network - AT+COPS? results:

    @afzal_m

    From here, we cant send any data as sim7000E does not support CoAp.
    So we need UDP direct to be supported 🙂

    The new t-mobile APN should resolve this problem. It will support UDP and add lot more supported hardware to the list, including SIMCOM modems 🙂


Locked
 

Looks like your connection to Internet of Things was lost, please wait while we try to reconnect.