Change of scrambling parameter


  • We finally have some new dates for the upgrade on our radio network.
    After this upgrade you’ll need to change some config parameters on your devices to match the new RAN version:

    AT+NCONFIG=CR_0354_0338_SCRAMBLING,TRUE
    AT+NCONFIG=CR_0859_SI_AVOID,TRUE

    Or (new syntax)

    AT+NCONFIG=“CR_0354_0338_SCRAMBLING”,"TRUE"
    AT+NCONFIG=“CR_0859_SI_AVOID”,“TRUE”

    The network change schedule is based on 3 regions:

    North = 16 April
    Mid = 17 April
    South = 18 April

    We will share a detailed map next week!



  • Cool, what does the scrambling parameter do?



  • Hi all! We have decided to not to divide the change in 3 regions and 3 nights.
    Change will be done during the night of tuesday 17 april to wednesday 18 april.



  • @afzal_m

    Will the new manual be ready before tuesday?
    Btw, why did you decide to implement the new scrambling feature?

    Good luck!



  • @andre-rodenburg

    You can find more details regarding CR 354 and CR 338 here:

    https://portal.3gpp.org/ChangeRequests.aspx?q=1&versionId=52094&release=189



  • @andre-rodenburg said in Change of scrambling parameter:

    @afzal_m

    Will the new manual be ready before tuesday?
    Btw, why did you decide to implement the new scrambling feature?

    Good luck!

    Hey Andre,

    It is necessary for the next generations nb-iot chipsets. Later on, it will not be possible to switch scrambling off anymore.



  • Another explanation:

    https://www.ericsson.com/research-blog/robust-scrambling-nb-iot-broadcast-channels/



  • I’ve updated the scrambling parameter but now I get +CSQ: 99,99. Is the network already done upgrading?



  • Not all cells are updated yet. Apologies.

    Just talked to my colleagues from our radio network team. It will take 3 hours from now before all cells will be updated



  • All cells updated!



  • Hi, just to inform you guys, on the SARA-N11 the following is happening:

    First apply the new scrambling parameters:

    AT+NCONFIG=“CR_0354_0338_SCRAMBLING”,"TRUE"
    AT+NCONFIG=“CR_0859_SI_AVOID”,“TRUE”

    After that the APN is cleared, so you’ll have to re-apply it:

    AT+CFUN=0
    AT+NCDP="172.16.14.22"
    AT+CGDCONT=1,“IP”,"oceanconnect.t-mobile.nl"
    AT+CFUN=1
    AT+COPS=1,2,“20416”

    After this, I got my device working again, check with (needs to be something else than 99,99):

    AT+CSQ

    I hope this helps!



  • Also note if you’re using the Sodaq_nbIOT library for Arduino, you’ll have to change the Sodaq_nbIOT.cpp manually. (Hopefully SODAQ will update them soon.)

    From these values on row 80:

    const uint8_t nConfigCount = 6;
    static NameValuePair nConfig[nConfigCount] = {
    { “AUTOCONNECT”, “FALSE” },
    { “CR_0354_0338_SCRAMBLING”, “FALSE” },
    { “CR_0859_SI_AVOID”, “FALSE” },
    { “COMBINE_ATTACH” , “FALSE” },
    { “CELL_RESELECTION” , “FALSE” },
    { “ENABLE_BIP” , “FALSE” },
    };

    To these:

    const uint8_t nConfigCount = 6;
    static NameValuePair nConfig[nConfigCount] = {
    { “AUTOCONNECT”, “FALSE” },
    { “CR_0354_0338_SCRAMBLING”, “TRUE” },
    { “CR_0859_SI_AVOID”, “TRUE” },
    { “COMBINE_ATTACH” , “FALSE” },
    { “CELL_RESELECTION” , “FALSE” },
    { “ENABLE_BIP” , “FALSE” },
    };


Locked
 

Looks like your connection to Internet of Things was lost, please wait while we try to reconnect.