Nieuwe settings voor NB-IoT hardware en API


  • Indien je hebt deelgenomen aan ons proefrit programma en al eerder online bent geweest, heb je nieuwe settings nodig om een connectie te maken op ons productienetwerk:

    Voor het aansturen van je hardware:

    • NCDP = (south interface IP, device access address): 172.16.14.20

    • APN = oceanconnect.t-mobile.nl

    • PLMN (AT+COPS) = 20416

    North Interface API IP address:

    • Dit heb je de vorige keer waarschijnlijk ingesteld in postman. Het nieuwe adres is nu: 160.44.201.248:8743

    • Wat betreft certificaten kun je dezelfde gebruiken die je tijdens de proefrit hebt gebruikt



  • En vergeet niet de nieuwe host toe te voegen bij de algemene settings van Postman!



  • Klopt het dat het device rapporteert in roaming mode te zijn? Zijn het internationale SIMs?

    Is er al zicht op een https koppeling tussen ocean connect en externe platforms? Het lukt me niet om een binding te maken anders dan http.



  • Yes! Welkom op het nieuwe netwerk @maartentc

    En het klopt wat je zegt, de batch van simkaarten die we nu hebben zijn global simkaarten en zijn dus aan het roamen. Waarschijnlijk kreeg je 0,5 bij het CEREG command? Daar keken wij de eerste keer ook raar van op. 🙂

    @ericbarten, heb jij een update over de andere vraag?



  • @afzal_m precies, +CEREG:0,5



  • Dag,

    ik krijg een error bij het invoeren van de APN:
    AT+CGDCONT=1,”IP”,”oceanconnect.t-mobile.nl”
    ERROR

    Ik kom zo niet verder.



  • @pieterhoenderken said in Nieuwe settings voor NB-IoT hardware en API:

    AT+CGDCONT=1,”IP”,”oceanconnect.t-mobile.nl”

    Dat is vreemd! Kun je mij even je simkaartnummer sturen via een pm?



  • Inmiddels werkt de setup. Na een 2e poging pakte hij de APN wel.



  • Helaas; ik krijg dezelfde ‘ERROR’ response als Pieter op het AT+CGDCONT=1,”IP”,”oceanconnect.t-mobile.nl” commando. Al vele malen geprobeerd en kom zo ook niet verder.

    Ik volg de stappen “So there are two steps” in Afzal’s installation quick guide onderin pagina 10 en bovenaan pagina 11.
    Ik krijg overigens ook geen repsonse op “Nuel Ok”. Zou daar ook geen ‘OK’ op moeten volgen?
    Wellicht is het gerelateerd aan het (ontbreken) van dekking?

    Terminal log:
    AT+CFUN=0
    OK
    AT+NCONFIG=AUTOCONNECT,FALSE
    OK
    AT+NCDP=172.16.14.20
    OK
    AT+CGDCONT=1,”IP”,”oceanconnect.t-mobile.nl”
    ERROR



  • Wat gek dit… ik heb even gezocht vanmiddag maar kan geen mogelijke oorzaken vinden @cvonken.

    Heb je getest of het wel werkt wanneer je eerst de radio module aanzet?

    Dus eerst AT+CFUN=1 en vervolgens de APN…

    Ben benieuwd!



  • @afzal_m Ik heb de issue gevonden. Ik had het AT commando letterlijk gekopieerd uit de PDF manual en daar zitten schijnbaar ‘vreemde’ quote karakters in. Misschien een Mac/Windows conversie?
    Ik heb het commando handmatig overgetikt en van " quotes voorzien en toen werkte het wel.
    Dus
    AT+CGDCONT=1,”IP”,”oceanconnect.t-mobile.nl” -> werkte niet
    AT+CGDCONT=1,“IP”,“oceanconnect.t-mobile.nl” -> werkt WEL
    Het is maar dat je het weet… 🙂
    Dank!



  • @cvonken ah thanks! goed om te weten voor ons @Jeroen

    Nu op naar de hello world Cyril 🙂



  • @afzal_m Ik zit nu in Frankrijk (Bretagne) en heb zojuist ondervonden dat hier nog geen NB-IoT coverage is. Mijn Sigfox sensor doet het wel (land of origin, dat mag dan ook wel), maar de LoRa sensoren ook niet, ik zit 20 km te ver van de dichtsbijzijnde TTN LoRa gateway. Gelukkig heb ik mijn eigen gateway bij me 😉 #NBholiday
    Die “Hello world” zal dus moeten wachten tot ik weer in NL ben volgende week. 😛



  • Ik krijg dit terug na executie van ‘login’ in Postman:

    <html>
    <body>
    <h1>504 Gateway Time-out</h1>
    The server didn’t respond in time.
    </body>
    </html>

    Certificaten, IP adr en passphrase staan goed volgens mij,
    iemand een idee?



  • @intron

    Bij mij kwam dit omdat ik niet in de juiste postman environment zat. Ergens rechtsboven in een dropdown. Ik stuur je morgen even een screenshot.



  • Op een andere machine werkte het wel, dus ik
    kan gewoon door. Maar bedankt nog:)


Locked
 

Looks like your connection to Internet of Things was lost, please wait while we try to reconnect.