Can't register endpoint


  • Hallo,

    Via de URL’s die we kunnen gebruiken om onze endpoint te registreren krijgen wij correcte feedback alleen bij “Get all registered devices” callback krijgen we melding:
    Get all registered devices:

    {
        "totalDevices": 0,
        "groupName": "EAP_NAME",
        "startOffset": 1,
        "endOffset": 10,
        "msg": "No endpoints matching the criteria",
        "code": 3044
    }
    

    Onze endpoint wordt dus niet gezien of geregistreerd, waardoor we geen berichten ontvangen kunnen ontvangen.

    Zie hier onze registratie stappen.
    Register application:

    {
        "msg": "Success",
        "code": 1000
    }
    

    (UI) Register endpoint (Device) CoAp:

    {
        "msg": "dsm.device.already.exist",
        "code": 999
    }
    

    (UI) Get all devices:

    {
        "iTotalRecords": 1,
        "iTotalDisplayRecords": 1,
        "sEcho": null,
        "aaData": [
            {
                "id": XX,
                "deviceId": "IMEI:XX",
                "networkId": "",
                "subscriberId": "",
                "model": "Sensor",
                "manufacturer": "Generic",
                "managed": true,
                "inUse": true,
                "os": "other",
                "protocolRealm": [
                    "NBIOT-SGI",
                    "LORA",
                    "DIAMETER",
                    "XIRGO",
                    "IMPACT_LWM2M",
                    "MBUS",
                    "OMA-DM",
                    "HTTP",
                    "MQTT-AL",
                    "VA"
                ]
            }
        ]
    }
    


  • @paul-koenen Wat zegt de api call “get all devices?” (dus niet registered). Bij deze api call heb ik twee devices in mijn lijst staan waarvan ik eentje heb gebruikt om data te sturen, ditzelfde device staat ook in de lijst “get all registered devices” (en de ander dus niet). Ik ga er daarom vanuit dat “get all registered devices” alleen devices laat zien die al een keer data gestuurd hebben… misschien dat @afzal_m dit kan bevestigen?



  • @andre-rodenburg said in Can't register endpoint:

    Wat zegt de api call “get all devices?” (dus niet registered)

    “Get all devices” geeft inderdaad het device terug.
    we hebben subscriptions op het device alleen we krijgen geen berichten op de endpoint en de “get all registered devices” toont geen device.



  • @paul-koenen Het beste wat je dan kan doen is alle devices / subscriptions verwijderen, je device offline laten en manual part 2 opnieuw doen. Pas als alle stappen voor het backend succesvol gedaan zijn op het device de attachment doen en probeer dan data te versturen. Ik heb gemerkt dat als je attached / data probeert te sturen voordat alles goed staat in postman je device niet meer bruikbaar is.



  • @andre-rodenburg We hebben alles verwijderd en opnieuw toegevoegd via de manual part 2. Helaas heeft dit niet mogen baten.
    Enige andere oplossingen nog?



  • @paul-koenen Heb je al een andere backend geprobeerd? Heb vandaag tijdens het installfest zowel UDP als CoAp gebruikt en bij beide protocollen komen de berichten netjes aan in de backend…



  • @Andre-Rodenburg het is ondertussen gelukt, het probleem zat hem in de Auth die we ingesteld hadden vanuit Drupal.


Locked
 

Looks like your connection to Internet of Things was lost, please wait while we try to reconnect.