Can not force SIMCOMM 7000E to connect to LTE over GSM


  • Hey everyone. I live in Turkey and bought Botletics SIMCOMM 7000E shield along with Hologram Global SIMCARD. For over a week, I am trying to connect to the LTE network but everytime it connects to GSM network.

    Prerequisite Knowledge:
    NB-IoT Coverage:
    Turkcell: B20 Vodafone: B8 bands according to the lin(https://halberdbastion.com/intelligence/geographic-regions/europe/turkey)

    Hologram Support In Turkey:
    Turkcell, Vodafone, Turk Telekom
    https://hologram.io/pricing/coverage/

    Below is the configuration I use;

    // LTE Only
     --> AT+CNMP?
    +CNMP: 38
    
    // Both NB*IoT and LTE-M, to be safe
     --> AT+CMNB?
    +CMNB: 3
    
    // 28602: Vodafone and 28603: Turk Telekom
    --> AT+COPS=?
    +COPS: (0,"TURKCELL","TURKCELL","28601",0),(0,"286 02","286 02","28602",0),(0,"286 03","286 03","28603",0),,(0,1,2,3,4),(0,1,2)
    
    // Network settings
     --> AT+CGDCONT?
    +CGDCONT: 1,"IPV4V6","","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0
    +CGDCONT: 13,"IP","hologram","0.0.0.0",0,0,0,0
    
    // Band settings, default
     --> AT+CBANDCFG?
    +CBANDCFG: "CAT-M",3,8,20,28
    +CBANDCFG: "NB-IOT",3,8,20,28
    
    // Automatic connection
     --> AT+COPS?
    +COPS: 0
    
    //  Roaming
     --> AT+CREG?
    +CREG: 0,5
    
    // Signal strength seems good
     --> AT+CSQ
    +CSQ: 29,99
    
    // Connected network: Turkcell GSM
     --> AT+CPSI?
    +CPSI: GSM,Online,286-01,0x8e36,34500,61 EGSM 900,-55,0,54-54
    
    
    

    Whatever I do, connection is always the GSM one instead of LTE. Do I miss a certain important AT command? Or maybe, there might be problem with Hologram or SIMCOMM7000E, or even with carriers.

    Thanks in advance.



  • This post is deleted!


  • I have done exactly in the comments and here are the results:

    AT+CGPADDR
    +CGPADDR: 1,0.0.0.0,0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0
    +CGPADDR: 13,0.0.0.0
    
     --> AT+CPSI?
    +CPSI: GSM,Online,286-01,0x8e36,34500,61 EGSM 900,-55,0,54-541
    


  • I didn’t post anything here… Who’s posting in my name?


 

Looks like your connection to Internet of Things was lost, please wait while we try to reconnect.