Firmware: BC95-B8


  • Hallo,

    Ik heb hier een mooie Quectel module een BC95-B8.
    Echter lees ik in verschillende topic’s dat je misschien een bepaalde firmware versie nodig hebt om deze correct te laten werken.
    bij het model geeft hij: "neul Hi2110"
    Firmware: “V100R100C10B650SP5”

    Graag hoor ik of deze out of the box zou moeten werken of niet.
    Als dat niet zo is, hoe kan ik dan de firmware precies updaten. Het kan aan mij liggen maar ik heb daarvoor nog niks gevonden op dit forum.

    mvg,



  • @MarcelVanSambeek in de handleiding kun je terugvinden dat SP11 nodig is, in deze map kun je de handleiding vinden:
    https://docs.t-mobile.nl/index.php/s/17OKzAGmB5YmC4m

    Compatible firmware versions currently are; V100R100C10B655SP2and V100R100C10B650SP11



  • @theesbrons said in Firmware: BC95-B8:

    @MarcelVanSambeek in de handleiding kun je terugvinden dat SP11 nodig is, in deze map kun je de handleiding vinden:
    https://docs.t-mobile.nl/index.php/s/17OKzAGmB5YmC4m

    Compatible firmware versions currently are; V100R100C10B655SP2and V100R100C10B650SP11

    Bedankt voor het antwoord, ik had dat ondertussen zelf ook gevonden, echter zie ik ook dat bepaalde personen bezig zijn geweest met het upgraden van firmware. Ik kan daar echter niks over vinden op het wereldwijde web.

    Moet ik dan weer terug naar mijn development board leverancier? Het is een Quectel eveluation board.
    Kan die dat aan mij leveren of moet ik direct bij Huawei aankloppen of moet ik naar neul.com?

    Ik hoor graag van jullie

    mvg,



  • Marcel,

    Deze dien je inderdaad op te vragen bij de leverancier van je hardware. Maar om het je even makkelijk te maken: https://docs.t-mobile.nl/s/Huvmz5cSzciPtlv

    In de folder software vind je het document Quectel_BC95_Firmware_Upgrade_via_Code_Loader_User_Guide_V1.1.pdf. Dit document heeft mij goed op weg geholpen met de firmware upgrade.

    Volgens mij heb je dan ook alleen hoofdstuk 3.2.2 (pagina 15) t/m 3.2.3 (pagina 19).

    Succes!



  • Misschien nog goed voor de nieuwe mensen die hier komen.
    Nadat je hebt geupdate heb je waarschijnlijk versie:
    V100R100C10B656

    deze werkt ook goed met T-Mobile.
    echter moet je de volgende commando’s voorlopig gebruiken om deze goed te laten werken.
    AT+NCONFIG=CR_0354_0338_SCRAMBLING,FALSE
    AT+NCONFIG=CR_0859_SI_AVOID,FALSE

    mvg, Wieger IJntema



  • Ik probeer mijn module te updaten van 655SP2 naar 656, heb de codeloader geinstalleerd, en de volgende bestanden geselecteerd(uit NB-Iot-B656.rar): application.bin & security.bin uit het mapje updater, protocol.bin uit de root directory. Het updaten gaat goed echter blijft de module in de bootloader na een reboot. Wanneer ik alle drie de files uit de root selecteer komt de eerste stap niet verder dan 5%. Iemand enig idee wat hier fout gaat? Ik kom van versie B655 dus ik kan alles vanaf pagina 12 negeren?


Locked
 

Looks like your connection to Internet of Things was lost, please wait while we try to reconnect.